CVE-2019-0211 Apache flaw allows getting root access via script

Original Post from Security Affairs
Author: Pierluigi Paganini

The privilege escalation vulnerability (CVE-2019-0211) affecting the Apache HTTP server could be exploited by users with the right to write and run scripts to gain root on Unix systems

An important privilege escalation vulnerability (CVE-2019-0211) affecting the Apache HTTP server could be exploited by users with the right to write and run scripts to gain root on Unix systems via scoreboard manipulation.

The flaw was discovered by Charles Fol and impacts all Apache HTTP Server releases from 2.4.17 to 2.4.38. The it has been addressed with the release of Apache httpd 2.4.39

“In Apache HTTP Server 2.4 releases 2.4.17 to 2.4.38, with MPM event, worker or prefork, code executing in less-privileged child processes or threads (including scripts executed by an in-process scripting interpreter) could execute arbitrary code with the privileges of the parent process (usually root) by manipulating the scoreboard. Non-Unix systems are not affected.” reads the changelog.

The CVE-2019-0211 vulnerability poses severe risks when the web server is used for running shared hosting instances, in this scenario, users with limited permissions could exploit the flaw to get root privileges using scripts and run commands on vulnerable Apache web servers.

The expert pointed out that it is very common to give unprivileged users the ability to write their own scripts.

Apache also addressed two other important severity control bypass security vulnerabilities, one of them tracked as CVE-2019-0217.

“In Apache HTTP Server 2.4 release 2.4.38 and prior, a race condition in mod_auth_digest when running in a threaded server could allow a user with valid credentials to authenticate using another username, bypassing configured access control restrictions.” continues the changelog.

The second one, tracked as CVE-2019-0215, affects Apache 2.4.37 and 2.4.38.

“In Apache HTTP Server 2.4 releases 2.4.37 and 2.4.38, a bug in mod_ssl when using per-location client certificate verification with TLSv1.3 allowed a client supporting Post-Handshake Authentication to bypass configured access control restrictions.” reads the changelog.

The complete list of flaws addressed in Apache httpd his available here.


Pierluigi Paganini

(SecurityAffairs – hacking, CVE-2019-0211)

The post CVE-2019-0211 Apache flaw allows getting root access via script appeared first on Security Affairs.


Go to Source
Author: Pierluigi Paganini

Leave a Reply

Your email address will not be published. Required fields are marked *

WordPress Appliance - Powered by TurnKey Linux